Investigating login issues for ThinkSmart Manager

Incident Report for ThinkSmart Manager Status

Resolved

The issue which was impacting user login is now resolved for ThinkSmart Manager.
Posted May 11, 2026 - 23:58 UTC

Investigating

We are currently investigating login issues for ThinkSmart Manager. We will provide an update as soon as progress is made on the investigation.
Posted May 11, 2026 - 22:39 UTC
This incident affected: Web Access and User Login.