SmartOffice Service Degradation - Ongoing Investigation

Incident Report for ThinkSmart Manager Status

Resolved

This issue has been resolved and all services are operating normally.
Posted Oct 24, 2025 - 21:19 UTC

Monitoring

The ThinkSmart team has scaled services and is seeing improvement in the backlog of device data. We are continuing to monitor the performance and will provide another update once the issue has resolved.
Posted Oct 24, 2025 - 14:49 UTC

Investigating

The ThinkSmart team is investigating service degradation for EU customers. The ThinkSmart Portal may show stale device data when updating or viewing the managed devices. The Engineering team is working on restoring the services and will continue to provide updates as we have more information to share.
Posted Oct 24, 2025 - 13:49 UTC
This incident affected: ThinkSmart Manager Services.